This topic contains 0 replies, has 0 voices, and was last updated by  burnt_52 4 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #33136


    Since the G4 is supposed to support up to a 64GB TF Card I have been trying to use one in my phone. When I put it in initially everything was fine, connected the phone to my computer as mass storage and started copying media. Once I disconnected my phone and checked only about 10GB of data had copied. Tried formatting in the phone and in the computer and trying this again and same result every time. I then removed it from my phone, copied 40GB of data to the card on the computer, removed it and put it in 2 other computers and both computers checked all the data on the card and no problems. I now put the card in the phone and its come up damaged storage. Format the card fine and tried that again to the same result.

    Has anyone tested 64GB MicroSD working or is there something I am doing wrong? Formatting as FAT32 and allocation as default.



    I have 64gb tf card working fine on my G4..The card had to be formatted on the phone, I then copied the 50GB data onto it via a card reader/usb connection on my computer and then put it back into the phone. Ive added photos, video and downloads to the 50 GB but kept back about 5GB for future use and had no problems at all to date.



    Adding a comment just to get follow-ups on email…



    I don’t have a JiaYu or any other Chinese phones (as yet) but I have had probs with microSD cards in the past.
    Now I only use Sandisk or Kingston. They have been trouble free in various phones and other devices.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.